phpCollab Community
Discuss everything phpCollab!

The forums are currently in READ-ONLY mode while we upgrade the forums.
Home » Community » Documentation » list system requirements on the install directions
list system requirements on the install directions [message #7687] Mon, 22 May 2006 15:44 Go to next message
Anonymous
Hi-
I used the pdf document describing how to install to put ver. 2.4. on Ububtu Linux 5.10. Maybe i missed something, but the most persistent problem i encountered occurred because i did not have certain packages installed. They were:

libgd2-xpm libgd2-xpm-dev php5-gd

in addition, the average noob may not know that they also will need:

apache2 php5 mysql-server libapache2-mod-auth-mysql libapache2-mod-php5 php5-mysql

On ubuntu, you use the apt command so the above packages would be installed with the command:

sudo apt-get install apache2 php5 mysql-server libapache2-mod-auth-mysql libapache2-mod-php5 php5-mysql libgd2-xpm libgd2-xpm-dev php5-gd

instructions on how to test if apache, mysql, php5, and gd libraries have been installed properly might also help? thanx

Re: list system requirements on the install directions [message #7694 is a reply to message #7687] Wed, 31 May 2006 21:17 Go to previous messageGo to next message
mindblender is currently offline  mindblender
Messages: 610
Registered: July 2003
Location: AZ
phpCollab contributor

Good idea.

I had originally planned on re-writing the whole setup piece for 2.5 to make it more user friendly, but due to time constraints and other activities, it will probably be in v3.
Re: list system requirements on the install directions [message #8275 is a reply to message #7694] Tue, 20 November 2007 21:51 Go to previous messageGo to next message
techstudios
Messages: 2
Registered: November 2007
phpCollab guest
Is the version 2.5 currently compatible with php5? I was able to install it and create most of the users etc. But not able to upload files.

Re: list system requirements on the install directions [message #8283 is a reply to message #8275] Tue, 04 December 2007 15:43 Go to previous messageGo to next message
beebum is currently offline  beebum
Messages: 64
Registered: July 2003
Location: Houston
phpCollab lover

OpenBSD 4.1 GENERIC#1435 i386
Apache/1.3.29 Server
php5-core-5.1.6p1
php5-mysql-5.1.6p1
mysql-server-5.0.33
PhpCollab v2.5

Everything is working just fine. Smile

[Updated on: Tue, 04 December 2007 15:43]

Report message to a moderator

Re: list system requirements on the install directions [message #8286 is a reply to message #7687] Wed, 05 December 2007 08:11 Go to previous messageGo to next message
mindblender is currently offline  mindblender
Messages: 610
Registered: July 2003
Location: AZ
phpCollab contributor

Check your directory permissions. Are you getting any errors when you try and upload a file?
Re: list system requirements on the install directions [message #8287 is a reply to message #8286] Thu, 06 December 2007 15:09 Go to previous messageGo to next message
beebum is currently offline  beebum
Messages: 64
Registered: July 2003
Location: Houston
phpCollab lover

No problems uploading files. Smile

drwxr-xr-x  37 root   daemon  1024 Oct 26 08:06 phpcollab
   drwxrwxrwx  67 root  daemon     1024 Oct 25 13:55 files
Re: list system requirements on the install directions [message #8810 is a reply to message #7687] Fri, 11 February 2011 05:40 Go to previous messageGo to next message
honey11 is currently offline  honey11
Messages: 4
Registered: February 2011
phpCollab guest
I would also like to know the system requirement to install the same. Tried to install it but failed. Showing errors. I am sure some packages are missing and that is why it is showing these errors. Anyone have any installation experience. Please help us by directing the right direction.
Re: list system requirements on the install directions [message #8818 is a reply to message #8810] Fri, 11 February 2011 17:53 Go to previous message
mindblender is currently offline  mindblender
Messages: 610
Registered: July 2003
Location: AZ
phpCollab contributor

honey11 wrote on Thu, 10 February 2011 21:40

I would also like to know the system requirement to install the same. Tried to install it but failed. Showing errors. I am sure some packages are missing and that is why it is showing these errors. Anyone have any installation experience. Please help us by directing the right direction.

What errors are you getting?

I have installed phpC on *unix boxes, OSX, and XAMPP on Windows.

Only requirements are:
Webserver
PHP 4+
MySQL 3+

The most common problems are usually permission related. In the ~/docs directory of phpC there is an install.txt file that explains what permissions are needed to be set for specific files and directories.
Previous Topic: Development documentation - what do you want? we'll do it!
Goto Forum:
  


Current Time: Sun Dec 21 21:35:54 CET 2014

Total time taken to generate the page: 0.22416 seconds